Website offline
Incident Report for LenoxBot
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 24, 2019 - 13:15 CET
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. Mar 22, 2019 - 17:46 CET
Identified
The website is currently offline and will be as soon as possible back online.
Posted 4 months ago. Mar 22, 2019 - 17:40 CET
This incident affected: www.lenoxbot.com.